mpega.include Fehler bei mp3files mit Cover

Amiblitz3 Includefragen

Moderators: Der Wanderer, Blackbird

mpega.include Fehler bei mp3files mit Cover

Postby Blackbird » 6. March 2016, 18:01

Hallo,

Ich habe gerade den TKPlayer auf die neue image.include umgestellt und dabei ist mir aufgefallen (kann auch schon vorher so gewesen sein ! )
das jedes mp3-file das ein eingebettetes Coverbild enthält der Player gnadenlos abschmiert (mpega.libary)..

Nachforschungen von mir haben nun ergeben das dies in der Funktion mpega_Read crasht (oder eben dann in der ffa_xxxxx) genauer hab ich das nun nicht verfolgt...

Thilo,
Hast du einen Ansatzpunkt woran das liegt ?
User avatar
Blackbird
Globaler Moderator
 
Posts: 666
Joined: 9. October 2013, 17:41
Location: Coburg

Re: mpega.include Fehler bei mp3files mit Cover

Postby Blackbird » 6. March 2016, 18:35

Da fällt mir noch ein, das man den Player auch noch ein wenig aufbohren könnte.... :o

Eine Playliste wäre fein als stupide Song nach Song abzuspielen, das dann noch mit einem shuffel (oder editierbar) versehen
und schon hat man das meiste was man "braucht" erschlagen 8-)

PS:
Ich sehe gerade eine Playlist ist ja schon vorhanden 8-)
Das könnte ich in einer Liste ähnlich wie bei AmigaAmp anzeigen und dann Sortbefehle einbauen
dann könnte man auch on the fly seine Musikstücke auswählen und abspielen anstatt stur eines nach dem anderen abspielen lassen :D

Ich sehe schon, da werde ich mal hand anlegen müßen :ugeek: :mrgreen:
User avatar
Blackbird
Globaler Moderator
 
Posts: 666
Joined: 9. October 2013, 17:41
Location: Coburg

Re: mpega.include Fehler bei mp3files mit Cover

Postby Der Wanderer » 7. March 2016, 03:29

Propiert doch mal ein anderes Tool (nicht AB3 tool) das via mpega die mp3 oeffnet. Wenn das auch crashed ist es leider die lib, da kann man nichts machen. Ansonsten koennte es noch am Stack liegen. Glaube nicht dass es am ab3 code liegt, da er das Image nicht interpretiert oder anfraegt.
User avatar
Der Wanderer
Globaler Moderator
 
Posts: 396
Joined: 3. September 2013, 10:26

Re: mpega.include Fehler bei mp3files mit Cover

Postby Blackbird » 8. March 2016, 19:05

Also ich habe als Referenz nun mal Tunenet und auch AmigaAmp getestet. Die beiden Programme spielen Lieder problemlos ab per mpega.library.

Wenn ich beim TKPlayer die Lieder abspielen will ranzt die Kiste ab...

Ich habe mal Spasseshalber per Musiktagger ein eingebettetes Coverbild entfernt, und dann wird auch das Lied problemlos abgespielt. Es liegt also defenitiv nicht an der Library...
User avatar
Blackbird
Globaler Moderator
 
Posts: 666
Joined: 9. October 2013, 17:41
Location: Coburg


Return to Includes

Who is online

Users browsing this forum: No registered users and 1 guest